Samsung отказалась устранять критические уязвимости в ряде смартфонов

Тема в разделе "Новости мобильных технологий", создана пользователем лис.хвост, 5 окт 2015.

  1. лис.хвост
    Оффлайн

    лис.хвост VIP Разработчик

    Сообщения:
    630
    Симпатии:
    983
    [​IMG]
    Samsung не стала выпускать обновления прошивок для Samsung Galaxy S4 (I9500) на базе Android Jelly Bean и Android KitKat, ограничившись лишь обновлением для аппаратов под управлением Android Lollipop. Об этом сообщают исследователи из компании QuarksLAB со ссылкой на представителей Samsung.

    По словам сотрудника QuarksLAB Джонатана Сальвана (Jonathan Salwan), Samsung была уведомлена о наличии двух уязвимостей в августе 2014 г. У компании ушло три месяца на выпуск заплатки, а ответила она на письмо QuarksLAB лишь в ноябре 2014 г., когда QuarksLAB опубликовала сведения об уязвимости в открытом доступе.

    Почему Samsung решила не выпускать патч для Jelly Bean, в компании не уточнили.

    Напомним, что Samsung Galaxy S4 — это флагман 2013 г. Он был выпущен в продажу в апреле 2013 г. с ОС Android Jelly Bean. Впоследствии были выпущены обновления до KitKat и Lollipop.

    Уязвимости
    Обе уязвимости содержатся в системном файле Samsung s3cfb_extdsp_ops.c — им присвоены номера CVE-2015-1800 и CVE-2015-1801 — и позволяют злоумышленнику манипулировать оперативной памятью устройства, взламывать защиту Address Space Layout Randomization (ASLR) и получать доступ к данным.

    Двухлетний Android
    Google, разработчик платформы Android, не считает целесообразным исправлять уязвимости в версиях Android, которые были выпущены два года назад или раньше. В январе 2015 г. компания отказалась от исправления одной из таких уязвимостей в Android Jelly Bean и более ранних версиях.

    Объясняя эту позицию, в Google заявили, что «исправлять уязвимость в компоненте, которому уже больше двух лет, было бы нецелесообразно с точки зрения самой безопасности». Это бы потребовало «изменения значительной части кода» и, в конечном счете, вызвать обратный эффект, посчитали в компании.

    Подобные примеры время от времени встречаются в индустрии. В июне 2015 г. о нежелании устранять уязвимость в 32-разрядной версии Internet Explorer 11 заявила Microsoft. В корпорации пояснили, что данная версия непопулярна.

    Уязвимости в аппаратах Samsung
    В июне 2015 г. стало известно о критической уязвимости в смартфонах Samsung Galaxy, затрагивающей около 600 млн устройств. Уязвимость позволяет получать доступ к датчикам, GPS, камерам и микрофону, незаметно устанавливать вредоносные приложения, вмешиваться в работу других приложений и операционной системы смартфона, перехватывать сообщения и прослушивать звонки, получать доступ к фотографиям и видеозаписям.

    Источник: Samsung отказалась устранять критические уязвимости в ряде смартфонов
     
    Kиpилл и orderman нравится это.
  2. Dragokas
    Оффлайн

    Dragokas Very kind Developer Команда форума Супер-Модератор Разработчик Клуб переводчиков

    Сообщения:
    4.476
    Симпатии:
    4.305
    Та и правильно. Чего напрягаться? Большой шумихи нет. А за апдейт все равно никто не заплатит. Задумаются лишь те немногие, кто беспокоится о безопасности. Обычные юзеры, которых большинство, в эту категорию не входят.
    Или наоборот - заплатили, чтобы не исправляли.
    --- Объединённое сообщение, 5 окт 2015 ---
    Вот это вообще абзац. В x64 исправить значит можно, а в x32 как будто код вообще другой, темнят не по детски.
     
    Kиpилл нравится это.

Поделиться этой страницей