Статья Выборочное суммирование в Excel

Dragokas

Very kind Developer
Команда форума
Супер-Модератор
Разработчик
Клуб переводчиков
Сообщения
6,131
Реакции
5,904
Баллы
648
Выборочное суммирование

5.jpg

Перед вами таблица, из которой видно, что разные заказчики несколько раз покупали у вас разные товары на определённые суммы. Вы хотите узнать, на какую общую сумму заказчик по имени ANTON купил у вас крабового мяса (Boston Crab Meat).

— В ячейку G4 вы вводите имя заказчика ANTON.

— В ячейку G5 — название продукта Boston Crab Meat.

— Встаёте на ячейку G7, где у вас будет подсчитана сумма, и пишете для неё формулу {=СУММ((С3:С21=G4)*( B3:B21=G5)*D3:D21)}. Сначала она пугает своими объёмами, но если писать постепенно, то её смысл становится понятен.

— Сначала вводим {=СУММ и открываем скобки, в которых будет три множителя.

— Первый множитель (С3:С21=G4) ищет в указанном списке клиентов упоминания ANTON.

— Второй множитель (B3:B21=G5) делает то же самое с Boston Crab Meat.

— Третий множитель D3:D21 отвечает за столбец стоимости, после него мы закрываем скобки.

— Вместо Enter при написании формул в Excel нужно вводить Ctrl + Shift + Enter.

Источник
 
  • Like
Реакции: E100
Сверху Снизу